Situation
There is an order generated in Firmhouse, but it is not pushed to your Shopify store. You're now trying to find out why the order was not pushed in Firmhouse and a way to push the order to Shopify again.
Possible causes
There are a few reasons on why Firmhouse was unable to generate the order in Shopify:
Email address of the customer is incorrect. For example a typo or incorrect domain.
API error or timeout when Firmhouse tried to generate the order in Shopify.
One of the products in the order doesn't exist anymore in Shopify.
To solve
First, you can head over to the Notifications page that you can access from the sidebar menu in the Firmhouse portal. This page will show all kinds important notifications and error messages on what's happening in your Firmhouse project, including any errors when integrating with Shopify.
Find the error message for the respective order. This should show you the reason why the order was not pushed to Shopify. If you cannot find the order, or if the error message is unclear: please contact our support so we can help you figure things out.
After you resolved the issue you can go to the order details page in Firmhouse. For example via the Orders menu in the sidebar. Or by first going to the customer detail page, and then clicking on the order from their order overview.
You can click the button Push to Shopify to push the order to Shopify. If after doing so you still get an error message, please review the Notifications page again so that you can see if the previous error was resolved or not.
๐ก Automatically get an email when an error Notification happens
You can subscribe to critical Notification error message via email. Go to the Notifications page and click Manage preferences in the top-right of the page. Here you can enter one or many email addresses that will be notified when there as an error in your Firmhouse project.